const regex = /^[a-zA-Z]:(\\\\[^\\ ]+)*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]:(\\\\\\\\[^\\\\ ]+)*', 'igm')
const str = `C:\\\\dd\\\\sd\\\\faf.txt true
c:\\\\ss\\\\dw\\\\fbf.txt true
D:\\\\ff\\\\d3\\\\fcf.txt true
d:\\\\da\\\\ds\\\\Df\\\\ff.txt true
2:\\\\ad\\\\dd\\\\ff false
2:\\ad\\\\dd\\\\ff false
d:\\da\\\\ds\\\\Df\\\\ff.txt false
c\\\\ss\\\\dw\\\\fbf.txt false
D:\\da\\\\ds\\\\Df\\\\ff.txt false
D:\\\\da\\\\ds\\Df\\\\ff.txt false`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}