# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z]:(\\\\[^\\ ]+)*"
test_str = ("C:\\\\dd\\\\sd\\\\faf.txt true\n"
"c:\\\\ss\\\\dw\\\\fbf.txt true\n"
"D:\\\\ff\\\\d3\\\\fcf.txt true\n"
"d:\\\\da\\\\ds\\\\Df\\\\ff.txt true\n"
"2:\\\\ad\\\\dd\\\\ff false\n"
"2:\\ad\\\\dd\\\\ff false\n"
"d:\\da\\\\ds\\\\Df\\\\ff.txt false\n"
"c\\\\ss\\\\dw\\\\fbf.txt false\n"
"D:\\da\\\\ds\\\\Df\\\\ff.txt false\n"
"D:\\\\da\\\\ds\\Df\\\\ff.txt false")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.