import Foundation
let pattern = #"^[a-zA-Z]:(\\\\[^\\ ]+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
C:\\dd\\sd\\faf.txt true
c:\\ss\\dw\\fbf.txt true
D:\\ff\\d3\\fcf.txt true
d:\\da\\ds\\Df\\ff.txt true
2:\\ad\\dd\\ff false
2:\ad\\dd\\ff false
d:\da\\ds\\Df\\ff.txt false
c\\ss\\dw\\fbf.txt false
D:\da\\ds\\Df\\ff.txt false
D:\\da\\ds\Df\\ff.txt false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)