re = /^[a-zA-Z]:(\\\\[^\\ ]+)*/im
str = 'C:\\\\dd\\\\sd\\\\faf.txt true
c:\\\\ss\\\\dw\\\\fbf.txt true
D:\\\\ff\\\\d3\\\\fcf.txt true
d:\\\\da\\\\ds\\\\Df\\\\ff.txt true
2:\\\\ad\\\\dd\\\\ff false
2:\\ad\\\\dd\\\\ff false
d:\\da\\\\ds\\\\Df\\\\ff.txt false
c\\\\ss\\\\dw\\\\fbf.txt false
D:\\da\\\\ds\\\\Df\\\\ff.txt false
D:\\\\da\\\\ds\\Df\\\\ff.txt false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end