#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[^\w\s]+"
Local $sString = "$$ this is a .... text : ha" & @CRLF & _
"" & @CRLF & _
"$%"
Local $sSubst = "*special_char*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)