import Foundation
let pattern = #"[^\w\s]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
$$ this is a .... text : ha
$%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*special_char*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)