use strict;
my $str = '$$ this is a .... text : ha
$%';
my $regex = qr`[^\w\s]+`mp;
my $subst = '*special_char*';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";