// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^\w\s]+").unwrap();
let string = "$$ this is a .... text : ha
$%";
let substitution = "*special_char*";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}