package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\w\s]+`)
var str = `$$ this is a .... text : ha
$%`
var substitution = "*special_char*"
fmt.Println(re.ReplaceAllString(str, substitution))
}