re = /[^\w\s]+/m
str = '$$ this is a .... text : ha
$%'
subst = '*special_char*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result