const regex = new RegExp('[^\\w\\s]+', 'gm')
const str = `\$\$ this is a .... text : ha
\$%`;
const subst = `*special_char*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);