# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>//mg;t' <<< "aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>"