const regex = /<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>', 'mg')
const str = `aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);