import Foundation
let pattern = #"<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)