import re
regex = re.compile(r"<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>", flags=re.MULTILINE)
test_str = ("aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>\n"
"aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)