$re = '/<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>/m';
$str = 'aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;