package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>`)
var str = `aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}