re = /<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>/m
str = 'aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result