use strict;
my $str = 'aaaaaa<bbb ccc>ddddd<dde<fff>ggg<hhh>iii>
aaaaaa<<<bb>cccc<ddd>>eeeee<ffff<gggg>>hhhh<iiii<jjjj>>jjj>';
my $regex = qr/<[^<>]*(<[^<>]*(<[^<>]*>[^<>]*)*>[^<>]*)*>/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";