# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a [^>]*href="https:\/\/www\.youtube\.com\/watch\?v=([^"&]+)[^>]*>(?s:.*?)<\/a>/<iframe width="560" height="315" src="https:\/\/www.youtube.com\/embed\/$1" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen><\/iframe>/gm;t' <<< "
<a target=\"_blank\" href=\"https://www.youtube.com/watch?v=pahhmV4WUUU\" >
</a>
"