using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a [^>]*href=""https://www\.youtube\.com/watch\?v=([^""&]+)[^>]*>(?s:.*?)</a>";
string substitution = @"<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/$1"" title=""YouTube video player"" frameborder=""0"" allow=""accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture"" allowfullscreen></iframe>";
string input = @"
<a target=""_blank"" href=""https://www.youtube.com/watch?v=pahhmV4WUUU"" >
</a>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}