const regex = new RegExp('<a [^>]*href="https://www\\.youtube\\.com/watch\\?v=([^"&]+)[^>]*>(?s:.*?)</a>', 'gm')
const str = `
<a target="_blank" href="https://www.youtube.com/watch?v=pahhmV4WUUU" >
</a>
`;
const subst = `<iframe width="560" height="315" src="https://www.youtube.com/embed/$1" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);