// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a [^>]*href="https://www\.youtube\.com/watch\?v=([^"&]+)[^>]*>(?s:.*?)</a>"#).unwrap();
let string = "
<a target=\"_blank\" href=\"https://www.youtube.com/watch?v=pahhmV4WUUU\" >
</a>
";
let substitution = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/$1\" title=\"YouTube video player\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}