use strict;
my $str = '
<a target="_blank" href="https://www.youtube.com/watch?v=pahhmV4WUUU" >
</a>
';
my $regex = qr~<a [^>]*href="https://www\.youtube\.com/watch\?v=([^"&]+)[^>]*>(?s:.*?)</a>~mp;
my $subst = '<iframe width="560" height="315" src="https://www.youtube.com/embed/$1" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";