import re
regex = re.compile(r"<a [^>]*href=\"https://www\.youtube\.com/watch\?v=([^\"&]+)[^>]*>(?s:.*?)</a>", flags=re.MULTILINE)
test_str = ("\n"
"<a target=\"_blank\" href=\"https://www.youtube.com/watch?v=pahhmV4WUUU\" >\n"
"</a>\n\n")
subst = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/$1\" title=\"YouTube video player\" frameborder=\"0\" allow=\"accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture\" allowfullscreen></iframe>"
result = regex.sub(subst, test_str)
if result:
print(result)