#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)"
Local $sString = "3.2% 1ST $100000 AND 1.1% BALANCE" & @CRLF & _
"3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY" & @CRLF & _
"$4000" & @CRLF & _
"3.3% 1ST $100000 AND 1.2% BALANCE" & @CRLF & _
"3.3% 1ST $100000 AND 1.2% BALANCE" & @CRLF & _
"3.2% 1ST $100000 1.1% BALANCE" & @CRLF & _
"2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")