import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d[\\d.]*)%\\s*1ST\\s*\\$(\\d+)[^\\n\\d]*(\\d[\\d.]*)%[^\\n\\d]*(\\d*)";
final String string = "3.2% 1ST $100000 AND 1.1% BALANCE\n"
+ "3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY\n"
+ "$4000\n"
+ "3.3% 1ST $100000 AND 1.2% BALANCE\n"
+ "3.3% 1ST $100000 AND 1.2% BALANCE\n"
+ "3.2% 1ST $100000 1.1% BALANCE\n"
+ "2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}