import Foundation
let pattern = #"^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3.2% 1ST $100000 AND 1.1% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY
$4000
3.3% 1ST $100000 AND 1.2% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE
3.2% 1ST $100000 1.1% BALANCE
2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)