const regex = /^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d[\\d.]*)%\\s*1ST\\s*\\$(\\d+)[^\\n\\d]*(\\d[\\d.]*)%[^\\n\\d]*(\\d*)', 'gm')
const str = `3.2% 1ST \$100000 AND 1.1% BALANCE
3.3% 1ST \$100000 AND 1.2% BALANCE AND \$3000 BONUS FULL PRICE ONLY
\$4000
3.3% 1ST \$100000 AND 1.2% BALANCE
3.3% 1ST \$100000 AND 1.2% BALANCE
3.2% 1ST \$100000 1.1% BALANCE
2.1% 1ST \$100000 AND 1.2% BALANCE PLUS \$2500`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}