using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)";
string input = @"3.2% 1ST $100000 AND 1.1% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY
$4000
3.3% 1ST $100000 AND 1.2% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE
3.2% 1ST $100000 1.1% BALANCE
2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}