package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)`)
var str = `3.2% 1ST $100000 AND 1.1% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY
$4000
3.3% 1ST $100000 AND 1.2% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE
3.2% 1ST $100000 1.1% BALANCE
2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}