$re = '/^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)/m';
$str = '3.2% 1ST $100000 AND 1.1% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY
$4000
3.3% 1ST $100000 AND 1.2% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE
3.2% 1ST $100000 1.1% BALANCE
2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);