// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)").unwrap();
let string = "3.2% 1ST $100000 AND 1.1% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY
$4000
3.3% 1ST $100000 AND 1.2% BALANCE
3.3% 1ST $100000 AND 1.2% BALANCE
3.2% 1ST $100000 1.1% BALANCE
2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}