import re
regex = re.compile(r"^(\d[\d.]*)%\s*1ST\s*\$(\d+)[^\n\d]*(\d[\d.]*)%[^\n\d]*(\d*)", flags=re.MULTILINE)
test_str = ("3.2% 1ST $100000 AND 1.1% BALANCE\n"
"3.3% 1ST $100000 AND 1.2% BALANCE AND $3000 BONUS FULL PRICE ONLY\n"
"$4000\n"
"3.3% 1ST $100000 AND 1.2% BALANCE\n"
"3.3% 1ST $100000 AND 1.2% BALANCE\n"
"3.2% 1ST $100000 1.1% BALANCE\n"
"2.1% 1ST $100000 AND 1.2% BALANCE PLUS $2500")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")