# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a.*?a>//gm;t' <<< "<b> this is a bold text </b>
some text here
<a href = \"#\"> this is a link </a>
<p class = \"class name\"> this is a paragraph </p>"