// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a.*?a>").unwrap();
let string = "<b> this is a bold text </b>
some text here
<a href = \"#\"> this is a link </a>
<p class = \"class name\"> this is a paragraph </p>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}