import Foundation
let pattern = #"<a.*?a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<b> this is a bold text </b>
some text here
<a href = "#"> this is a link </a>
<p class = "class name"> this is a paragraph </p>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)