using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?a>";
string substitution = @"";
string input = @"<b> this is a bold text </b>
some text here
<a href = ""#""> this is a link </a>
<p class = ""class name""> this is a paragraph </p>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}