import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?a>";
final String string = "<b> this is a bold text </b>\n"
+ "some text here\n"
+ "<a href = \"#\"> this is a link </a>\n"
+ "<p class = \"class name\"> this is a paragraph </p>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}