re = /<a.*?a>/m
str = '<b> this is a bold text </b>
some text here
<a href = "#"> this is a link </a>
<p class = "class name"> this is a paragraph </p>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result