package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?a>`)
var str = `<b> this is a bold text </b>
some text here
<a href = "#"> this is a link </a>
<p class = "class name"> this is a paragraph </p>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}