#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<a.*?a>"
Local $sString = "<b> this is a bold text </b>" & @CRLF & _
"some text here" & @CRLF & _
"<a href = "#"> this is a link </a>" & @CRLF & _
"<p class = "class name"> this is a paragraph </p>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)