const regex = /<a.*?a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?a>', 'gm')
const str = `<b> this is a bold text </b>
some text here
<a href = "#"> this is a link </a>
<p class = "class name"> this is a paragraph </p>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);