# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<[^>]*>(*SKIP)(*F)|(hello)/<span style="background:yellow">$1<\/span>/gi;t' <<< "<div class=\"hello\"> Hello world < hello world?! </div>"