import Foundation
let pattern = #"<[^>]*>(*SKIP)(*F)|(hello)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<div class="hello"> Hello world < hello world?! </div>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span style="background:yellow">$1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)