$re = '/<[^>]*>(*SKIP)(*F)|(hello)/i';
$str = '<div class="hello"> Hello world < hello world?! </div>';
$subst = "<span style=\"background:yellow\">$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;