using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[^>]*>(*SKIP)(*F)|(hello)";
string substitution = @"<span style=""background:yellow"">$1</span>";
string input = @"<div class=""hello""> Hello world < hello world?! </div>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}