// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<[^>]*>(*SKIP)(*F)|(hello)").unwrap();
let string = "<div class=\"hello\"> Hello world < hello world?! </div>";
let substitution = "<span style=\"background:yellow\">$1</span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}