package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<[^>]*>(*SKIP)(*F)|(hello)`)
var str = `<div class="hello"> Hello world < hello world?! </div>`
var substitution = "<span style="background:yellow">$1</span>"
fmt.Println(re.ReplaceAllString(str, substitution))
}