re = /<[^>]*>(*SKIP)(*F)|(hello)/i
str = '<div class="hello"> Hello world < hello world?! </div>'
subst = '<span style="background:yellow">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result